No components marked as affected
Resolved
This incident has been resolved.
Investigating
Block processing in MATIC has experienced a time delay greater than 600 seconds for the past 5 minutes.
·