No components marked as affected
Resolved
This incident has been resolved.
Investigating
Block processing on the MATIC service has experienced a time delay greater than 600 seconds throughout the last 5 minutes.
Error in d_help_add_block logs
```
2025-11-19 18:40:36.144 [INFO] Enter pre-crash
if receipt['transactionHash'] == tx_hashes[idx] and receipt['transactionIndex'] == idx:
File "/crystal_matic/build/./cb_init_blockchain/client/evm/helpers.py", line 82, in sort_receipts
sort_receipts(block_entry.block_data['number'], block_entry.receipts, tx_hashes)
File "/crystal_matic/build/./currency/matic/plugins/cb_init_blockchain/job_help_add_block.py", line 250, in enrich_with_receipts
if not self.collector.enrich_with_receipts(blocks_chunk):
File "/crystal_matic/build/./cb_init_blockchain/strategy/job_help_add_block.py", line 136, in process_chunk
last_parsed_height = self.process_chunk(start_height=start_from_height, batch=batch)
File "/crystal_matic/build/./cb_init_blockchain/strategy/job_help_add_block.py", line 163, in iteration
self.strategy.iteration(start_from_height=start_from_height)
File "/crystal_matic/build/./cb_init_blockchain/strategy/job_help_add_block.py", line 262, in main
next(gen)
File "/crystal_matic/.env/lib/python3.10/site-packages/backend_tools/daemon.py", line 239, in execute_generator
Traceback (most recent call last):
```